Conectarse con nosotros

Hardware

Intel confirma otra vulnerabilidad en sus CPUs de 7ma. Generación y anteriores

Publicado

el

Si creían que ya no veríamos más vulnerabilidades por un tiempo, estaban equivocados. Intel confirmó otra vulnerabilidad en sus CPUs de 7ma. Generación y anteriores, nuevamente en el área de especulación. Intel se refiere a esta vulnerabilidad como MDS, las siglas de Microarchitectural Data Sampling.

Nuevamente, permite que los atacantes logren sacar información que no deberían, en este caso, de los distintos buffers del CPU, ya sean buffers de caché, o los buffers que utilizan los hilos. La información obtenida puede ir desde páginas web que estamos visitando, hasta alguna contraseña, por lo que el ataque puede ser peligroso.

Aparentemente, según menciona Intel, los ataques pueden prevenirse deshabilitando Hyper-Threading, ya que es la parte donde más interviene la especulación. La solución que tienen sin desactivar HyperThreading tiene pérdidas de rendimiento del 9%, ya que consiste en vaciar constantemente los buffers, algo que no es para nada eficiente, y por eso dudan implementarla, y están buscando otra solución aunque aún no la tienen.

Si usan un procesador de 8va. o 9na. Generación, no deberían tener problemas, ya que la sección afectada fue modificada en esas dos generaciones. Si usan la 7ma. o alguna generación anterior, si deberían tener más precauciones.

¿Que opinan sobre las constantes apariciones de vulnerabilidades? ¿Creen que veremos más?

 

Fuente: TechPowerUp